Using Codeplane with Codenvy

If you have Git repositories at Codeplane you can migrate your projects to Codenvy. Here’s how you can setup SSH connection to your Codeplane workspace and clone, push, pull and fetch repositories.

SSH Key Configuration

First off, you should configure SSH keys:

  • go to Window > Preferences > SSH Keys and press Generate Key button. Enter hostname as:
codeplane.com

(no www or https!) and click OK

  • the key will appear in the list of SSH keys. Click View and copy the key to clipboard. Make sure you’ve selected and copied the entire key text
  • go to your Codeplane account, SSH Public Keys section
  • add a new key

Clone From Codeplane

The easiest way to migrate your projects to Codenvy is to clone Codeplane repository with the project’s source code:

  • go to File > Import Project > Import From Location
  • copy and paste the repository Git URL
  • modify project’s name, if appropriate, and click Import

Push to Codeplane

To push to Codeplane, you first need to add a remote repository in Codenvy at Git> Remotes > Add (unless it is already there after cloning). Enter the repository name and its SSH Git URL which should look like:

git@codeplane.com:test/new.git

Having added a remote repository, you can push to Codeplane at Git > Remote > Push. The repository you have just added should appear in the list of remote repositories. For more info see Remote Repositories.